Regional FlagChatFrame.lua:737: bad argument #1Source
avatar
Pariahdark
Target Source
#0 - 2007/12/31 06:53:47 PM
i keep getting this message at random:

Interface\FrameXML\ChatFrame.lua:737: bad argument #1 to 'strlower' (string expected, got nil)

it tends to happen on random kills just as they go down. at first i thought it could be because of an addon because i occationally get a message in chat box saying something like, "interface action failed because of an addon". however this has turned out not to be the case. i've updated my addons and still got it. then i turned off all addons and it came up again. the message has been getting to be real annoying. almost as bad as the fact that my textures (icons) fade in and out to different transparencies that force me to alt tab out and back into game to fix

avatar
Blue Poster
Target Source
#1 - 2007/12/31 06:56:24 PM
Pariahdark,

Please close down WoW and remove the WTF, Interface and Cache folders from the World of Warcraft game directory. These folders contain temporary data and frequently altered files that may have become corrupted. This will also remove any custom UI's that may contribute to the problem as well.

If you are using Windows Vista you may need to remove the WTF, Cache and Interface folders from this directory as well. Vista saves user settings like this in a few places.
C:\Users\<name>\AppData\Local\VirtualStore\Program Files\World of Warcraft

You can move these folders to the desktop or another directory if you wish to retain the data, however for now please start WoW without those folders present. Also do not use any third party programs to start WoW; often some custom UI's will place a shortcut for you to start WoW from, please use the (Launcher.exe) in the World of Warcraft directory.

For the icons, it is most likely that you have an Intel Video card that needs its drivers updated from http://www.intel.com if you know what video card you have, I can help in locating the drivers. If you do not know, the Display tab of the dxdiag will tell you, (Start/Run type "dxdiag").

Edit: oops, it was moved to the UI Forum. I can help here as well, just can't stay long, Tech Support is home.

avatar
Blue Poster
Target Source
#3 - 2007/12/31 07:03:30 PM
Q u o t e:
Sorry, Evanm, but in this case you're wrong. The 'strlower' error is a known issue with the WoW client UI that is being fixed in the upcoming 2.3.2 patch. There is no need to reset your user interface (at least not for this specific issue). Many of the issues with "An action has been blocked" are also being fixed in 2.3.2.


Sounds good, I generally don't stay on top of UI errors.

avatar
Blue Poster
Target Source
#5 - 2007/12/31 07:06:34 PM
The icons problem the OP is having is likely drivers though. I'll stay in the thread for that a little more. I've seen that happen with many Intel cards that are using 2005 drivers.