Regional FlagStuck on....Source
avatar
Kimmers
Target Source
#1 - 2014/06/27 07:59:00 PM
Currently stuck on "Starting Battle.net." I've even restarted it and my computer. I've been playing Alpha and in fact, I had just created a template character when the game crashed. When I brought it back up it just ended up sitting at the "Starting Battle.net."

Anyone else having this issue?

avatar
Community Manager
Target Source
#6 - 2014/06/27 08:12:00 PM
06/27/2014 01:10 PMPosted by Stab
Lots of restarts to get ready for beta launch in an hour

Correct.

Everyone keep in mind that we're taking steps on our end to prep for unlocking the beta content at 2 p.m. when stress testing begins. :)

avatar
Community Manager
Target Source
#9 - 2014/06/27 08:20:00 PM
06/27/2014 01:14 PMPosted by Zushiba
06/27/2014 01:12 PMPosted by Zarhym
...
Correct.

Everyone keep in mind that we're taking steps on our end to prep for unlocking the beta content at 2 p.m. when stress testing begins. :)


Should I delete/redownload the alpha/beta client?
I've had this option for around the last 3 weeks http://i.imgur.com/AXgtxgb.png

It's been maintaining the client but I wasn't in the alpha, I figured I'd leave the battle.net client alone and do it's thing.

EDIT: When I try to download the beta client from my account page, it opens the Battle.net application to that client and a red progress bar shows up that spans to 100%, it stays there for about a minute then goes away like "I'm ready, let's go!"

That sounds like something you might want to take to the Beta Technical Support forum.