Regional FlagBlizz wont allow us to play ( not banned ) (Show MVP Posts)Source
Target Source
#1 - 2013/03/16 01:19:00 PM
My wife and i are having a few issues with the game atm. Her authenticator is on her mobile phone which no longer works as she dropped it and the screen shattered. So we decided to get the authenticator removed from her account so we could continue playing untik it was fixed.

But lo and behold we cant remove it. Because her last name was different from her account. ( since we only been married 3 months ) So we had to change her account details and they wanted a copy of our certificate to prove the change. but when we tried submitting it.........nothing. no error message no ty we will get back to you, nothing.

So we call their support line, twice. first time we get a link to the "correct" form which wont except pdf files and none over 5mb....... so we try converting it and get it to a gif file and its only 111kb. so we try agian and.........nothing. no error messages and no ty please wait.

So on the second call we asked how to resolve this and they basically said they cant do squat with out the files. so my wife cannot play the game until the authenticator is removed and they wont remove it until we submit files to them that we are not allowed to / unable to submit.
Since we have done everything they asked of us and are still refusing to help i ask them why cant we provide some other information? like secret question answers or something else....... "sorry that information can be obtained anywhere"........ really ? anywhere? so whats the point in them?

We were then prompted to download another internet browser. we dont download anything unless its been tried and tested. so wow / swtor /guild wars that sort of thing fine. updates for our adobe files and the like fine. but anything untested we arnt downloading because of virus scams and the like.

It feels like they are chargin us to play "phone tech support" instead of playing the game.

Anyone got any ideas on how we can resolve this without some form of screaming ?

Customer Service
Target Source
#9 - 2013/03/16 02:02:00 PM
I would try using another browser as was suggested or at least clearing the cookies/cache of your existing browser.

Clearing Browsers Cookies and Cache:

Ellifara's suggestion of creating a jpg may also help.