Regional FlagVoidwalker - Sacrifice BuggedSource
avatar
Anhataway
Target Source
#1 - 2012/01/19 03:28:00 PM
I used my voidwalker's sacrifice shield and it didn't absorb anything. I used it three times more and the same result. Voidwalker's sacrifice doesn't absorb any damage!

avatar
Customer Service
Target Source
#2 - 2012/01/19 04:31:00 PM
Greetings Anhataway,

Thanks for taking the time to make this post, and to submit this report, but could I possibly ask you a few additional questions before were able to forward the report on to our QA team for investigation?

Now, Ive just tested this in-game myself, and the Sacrifice shield worked perfectly for me. This means that potentially the situation you experienced was specific to the mobs you were fighting at the time, or even specific to the set of circumstances.

If you could therefore please return and provide us with some detailed steps as to how this originally occurred, well then hopefully be able to reproduce the issue. :)

avatar
Customer Service
Target Source
#6 - 2012/01/19 05:17:00 PM
Greetings Beloresin,

Im afraid to say that your feedback on the game design is sadly misplaced in this particular forum were unfortunately not able to pass on thoughts or comments about game mechanics to our development team, and those would be far better placed directly within the relevant class forum (so that our Community team can read them and pass on any feedback as appropriate).

Id like to ask you, therefore, to please refrain from using this thread (which was originally created for the purpose of reporting a potential bug) for such posts.