Regional FlagProt Warrior artifact weapon! missingSource
avatar
Bearicus
Target Source
#1 - 2018/02/09 08:04:00 AM
Hello, im having issues on obtaining my 3rd artifact weapon. for prot. i have the arms and fury..... but not sure how to start the quest for the 3rd

avatar
Support Forum Agent
Target Source
#2 - 2018/02/09 07:51:00 PM
Bearicus, it looks like you used the level 110 boost on this Warrior. Did you by chance select Protection as the spec?

If so, it is possible that you are experiencing a bug with the boost that impacted a number of folks. The overall issue was resolved going forward, but we couldn't get it to apply retroactively so it is necessary for a Game Master to step in.

Please let me know. :)

~~~~~~~~~*~~~~~~~~~*~~~~~~~~~*~~~~~~~~~*~~~~~~~~~

How's my driving? Click me.

avatar
Support Forum Agent
Target Source
#5 - 2018/02/09 10:32:00 PM
02/09/2018 02:30 PMPosted by Bearicus
How exactly do I involve the game master. I'm currently at work.

You already have a ticket open, Bearicus, that is all that is needed. I just wanted to make sure that you opted for Protection when you boosts, to confirm that looks to be the issue.

avatar
Support Forum Agent
Target Source
#7 - 2018/02/09 10:51:00 PM
Queue times vary depending on what is going on. Patch 7.3.5 and the related launches around that caused a lot of contacts. We're starting to normalize now, but queue times are still a little higher than normal.

The last time I looked your ticket was in the hands of a Game Master, my guess is that it should be resolved fairly soon.