Regional FlagNew patch required?Source
avatar
Pacdoom
Target Source
#1 - 2014/09/24 01:11:00 AM
My PTR is up to date, but whenever I launch the PTR from the battle.net app, I get an error saying I need to download the latest patch.....am I missing something here? It downloaded a patch last night, and is saying I'm all up to date.

Please don't tell me I'm gonna have to redownload the PTR :<

avatar
Quality Assurance
Target Source
#2 - 2014/09/24 01:20:00 AM
My PTR is up to date, but whenever I launch the PTR from the battle.net app, I get an error saying I need to download the latest patch.....am I missing something here? It downloaded a patch last night, and is saying I'm all up to date.

Please don't tell me I'm gonna have to redownload the PTR :<


When you look at your battle.net app, what build does it say you're updated to?