We have updated our Terms of Service and Privacy Policy.
Regional FlagForge anvil seems to have quit workingSource
Target Source
#1 - 2014/08/11 12:06:00 AM
My anvil in my lvl 2 forge seems to have bugged out. Worked fine in lvl 1 forge and I thought it worked fine for my lvl 2 at least for a while. I've added a follower to the forge and made 2 true steel gauntlets, smoldering helm and chest, the true steel sword and shield. But now cannot do my daily ingot cd on my forge or make any other armor (but I'm not getting any secrets of draenor BS anymore anyways :P<<another bug?). I'm lucky that I do have a thermal anvil that I brought over on my copied character, otherwise I'd be up the proverbial creek. But I hate to use it except for emergencies.

Reported in game, but I was wondering if anyone else has previously working anvil breaking.

Game Designer
Target Source
#7 - 2014/08/12 06:20:00 AM
Forges for all blacksmithing buildings (horde/alliance) are fixed in the next build. Thanks for the reports.