Help
Regional FlagX-53 Touring Rocket GoneSource
avatar
Burrzerk
Target Source
#1 - 2014/02/18 11:31:00 PM
Ive had this mount since it came out now its gone, i use it all the time to fly me and my wife places and now i don't have it any more. The whole reason i did the RaF thing was to get a two person flying mount.

avatar
Community Manager
Target Source
#4 - 2014/02/18 11:39:00 PM
Hello Burrzerk, we're aware of an issue that's causing pets or mounts to not appear on the account. We're working on a fix for the issue.

From the Support article.

    We're fixing an issue that causes some players' pets and mounts to disappear. If one of your pets or mounts vanished from your in-game journal, please wait and check your journal again after our next realm restart. Your missing pets and mounts should reappear then.

avatar
Community Manager
Target Source
#130 - 2014/02/20 02:36:00 AM
There's a thread being maintained on the Customer Service forum with more information on what happened. We're working to restore the missing mounts and Battle Pets as quickly as possible.

Missing Pets or Mounts
http://us.battle.net/wow/en/forum/topic/11763816937

avatar
Community Manager
Target Source
#158 - 2014/02/20 07:46:00 PM
There was a fix implemented during maintenance that should restore all of the Battle Pets and mounts that have been missing when you log back in. Additionally, the mounts may be re-mailed to you in the mailbox.

If you require further assistance, please get in touch with our Customer Service staff in the thread titled: Missing Pets or Mounts: Part II.

avatar
Community Manager
Target Source
#163 - 2014/02/20 08:23:00 PM
02/20/2014 12:16 PMPosted by Gimolos
A novel idea I know but maybe you guys should just fix everything you broke and not patch again till the expac? Nothing in this patch that was remotely worth this kind of downtime.

"Everything"? Well, because you asked so nicely; check out the 5.4.7 Hotfixes that just went up.